Квадратное уравнение  в Excel

Квадратное уравнение  в Excel

В этой статье вы узнаете как решить квадратное уравнение в Excel на конкретном примере. Подробно разберем решение несложно задачи с картинками.

Ход решения

Решение квадратного уравнения в Excel

Запустим программу Microsoft Office Excel. Я пользуюсь 2007 версией.  Для начала объединим ячейки A1:A5 и запишем в них формулу квадратного уравнения в виде ax2+bx+c=0.Далее нам нужно возвести x в квадрат, для этого нужно сделать цифру 2 надстрочным интервалом. Выделим двойку и нажмем правой кнопкой мыши.

Формат ячеек в Excel

Надстрочный интервал в Эксель

Получим формулу вида ax2 +bx+c=0

В ячейке A2 введем текстовое значение a= , в ячейке A3 b= и в ячейке A4 с= соответственно. Эти значения будут вводиться с клавиатуры в следующих ячейках (B2,B3,B4).

Введем текст для значений, которые будут считаться. В ячейке C2 d=, C3 x1= C4 x2=. Подстрочный интервал для xсделаем аналогично надстрочному интервалу в x2

Перейдем к вводу формул для решения

Дискриминант квадратного трехчлена равен b2-4ac

В ячейку D2 введем соответствующую формулу для возведения числа во вторую степень:

=B3^2-4*B2*B4

Решение квадратного уравнения в Excel

Квадратное уравнение имеет два корня, в случае если дискриминант больше нуля. В ячейку C3 введем формулу для x1

=ЕСЛИ(D2>0;(-B3+КОРЕНЬ(D2))/(2*B2);»Корней нет»)

Для расчета x2 введем похожую формулу, но со знаком плюс

=ЕСЛИ(D2>0;(-B3-КОРЕНЬ(D2))/(2*B2);»Корней нет»)

Соответственно при введенных значениях a,b,c сначала считается дискриминант, если его значения меньше нуля выводится сообщение «Корней нет», иначе получаем значения xи x2.

Защита листа в Excel

Нам нужно защитить лист, на котором мы производили расчеты. Без защиты нужно оставить ячейки, в которые можно вводить значения a,b,c, то есть ячейки B2 B3 B4. Для этого выделим данный диапазон и зайдем в формат ячеек, перейдем во вкладку Рецензирования, Защитить лист и уберем флажок с позиции Защищаемая ячейка. Нажмем кнопку OK, подтвердив внесенные изменения.

Защита ячеек в Эксель

Этот диапазон ячеек будет не защищен при защите листа. Выполним защиту листа, для этого перейдем на вкладку Рецензирование пункт Защита листа. Пароль наберем 1234. Нажмем OK.

Теперь мы сможем изменять значения ячеек B2,B3,B4. При попытке изменения других ячеек мы получим сообщение следующего содержания: «Ячейка или диаграмма защищена от изменений. А так же совет по снятию защиты.

Так же вас может заинтересовать материал как закрепить область в Экселе.

3 комментариев к “Квадратное уравнение  в Excel”

Оставьте комментарий